Зона аплоадеров » Программы » XAMPP 5.6.15-2 / 7.0.3-1 Win32 + Portable
XAMPP 5.6.15-2 / 7.0.3-1 Win32 + Portable
Добавил: u2ua | 26-02-2016, 08:50 | Просмотров: 63 | Комментариев: 0
XAMPP 5.6.15-2 / 7.0.3-1 Win32 + Portable
XAMPP 5.6.15-2 / 7.0.3-1 Win32 + Portable | 108/118/134/134 MB


XAMPP is a cross-platform Apache distribution enriched with third-party applications, namely MySQL, PHP and Perl. It was designed as a web server that can be a friendly assistant in website creation and maintenance. XAMPP provides developers with an easy and comfortable way to test dynamic webpages without access to the Internet. It also includes the newest versions of Mercury and Tomcat.
With XAMPP, you can manage MySQL and SQLite databases and you can create a remote host using FileZilla FTP server (also included in the package). This is useful for the administration of large Content Management Systems (CMS).

The installation process requires user intervention only to ask if the components should be installed as Windows services too. You don’t have to decide now, seeing how this is configurable from XAMPP’s control panel. This is also the only interface with the user and only from here you can perform server configurations.

By default, all services are stopped; therefore, you need to manually start the ones you need and administer them at the same time. In Service Settings you can choose for the XAMPP Control Panel to run as service, and automatically make specific modules active at startup. In addition, you can set up an account and password for secure access.

XAMPP receives regular updates in order to keep up with the latest version of the included components. Its developers are successful in their attempt to provide an up-to-date web server that can be used for website testing and maintenance.

New in version 5.6.15-2 / 7.0.3-1 (February 24, 2016):
- Impact: An attacker could have access phpMyAdmin from remote servers bypassing the XAMPP security approach. This issue affects all platforms. All users running an affected release should either upgrade or use one of the workarounds immediately.
- Workaround: If you already have a previous version installed and you can not install a new XAMPP, please do the following changes in your XAMPP files: Windows: C:\xampp\apache\conf\extra\httpd-xampp.conf
Alias /phpmyadmin "/xampp/phpMyAdmin/"

AllowOverride AuthConfig
- Require all granted
+ Require local
+ ErrorDocument 403 /error/XAMPP_FORBIDDEN.html.var



Version 5.6.15-2 Includes: Apache 2.4.17, MariaDB 10.1.10, PHP 5.6.15, phpMyAdmin 4.5.1, OpenSSL 1.0.2, XAMPP Control Panel 3.2.2, Webalizer 2.23-04, Mercury Mail Transport System 4.63, FileZilla FTP Server 0.9.41, Tomcat 7.0.56 (with mod_proxy_ajp as connector), Strawberry Perl 7.0.56 Portable

Version 7.0.3-1 Includes: Apache 2.4.18, MariaDB 10.1.10, PHP 7.0.3, phpMyAdmin 4.5.1, OpenSSL 1.0.2, XAMPP Control Panel 3.2.2, Webalizer 2.23-04, Mercury Mail Transport System 4.63, FileZilla FTP Server 0.9.41, Tomcat 7.0.56 (with mod_proxy_ajp as connector), Strawberry Perl 7.0.56 Portable

OS: Windows Vista / 2008 / 7 / 2012 / 8 / 10


Категория: » Программы
Теги: XAMPP, Portable

Информация
Посетители, находящиеся в группе Гости, не могут оставлять комментарии к данной публикации.